Troubleshooting connection to RASPISHAKE FDSN server

Hello, I am trying to download RaspberryShake data using Obspy’s FDSN interface. I am having trouble connecting to the RaspberryShake client. I believe this is something specific to the server which I am trying to connect from, but I’m not sure how to go about troubleshooting the problem–any tips are much appreciated. Details below.

The problem

When I run

from obspy.clients.fdsn import Client
client = Client('RASPISHAKE')

I get the following error:

FDSNNoServiceException: No FDSN services could be discovered at ''. This could be due to a temporary service outage or an invalid FDSN service address.

I am using obspy version 1.4.0, installed via conda.

What I’ve tried

  • Visiting – the website works fine and loads normally in a browser
  • Accessing a different data provider. This also seems to work fine. For example, Client('NCEDC') runs as expected.
  • Running Client('RASPISHAKE') on my local machine instead of the remote server where I want to download the data. This also works as expected.
  • Re-installing obspy in a new conda environment with no other packages. This does not change the behavior on the remote server.

So it seems like there’s something specific about the configuration of the remote server I’m using that is blocking RASPISHAKE but not other data providers. I’m not sure what some possible next steps might be in terms of debugging and fixing this. I would really appreciate any tips!

I can connect to that FDSNWS base URL just fine.

With debug option, you might see a little more detail: client = Client('RASPISHAKE', debug=True)
But since the connection is rejected somewhere you probably won’t get much info out of it. This seems to be a more low level issue outside of obspy… You could try to ping the server on command line (ping Things I can think of…

  • your server has a firewall restricting outgoing traffic, you could use wget ... or curl to download some internet resource to check. it’s quite unusual that https ports for outgoing are blocked though
  • raspishake has you blocked (could be automatic blocks kicking in if you have a very high amount of requests, try on command line e.g. wget ''
  • there might be a problem with DNS resolution, but that should also show up when trying to ping like mentioned above

Hi Tobias, thanks for these helpful suggestions. After some more experimentation I think my IP address is blocked by raspishake–I’ll reach out to them to resolve this issue.