Trigger ar_pick

I used the obspy ar_pick function for P and S arrivals on some traces. I have two issues:

  1. For a particular trace I used to have access violation error but worked on others. A rough fix was to use a try and except.
  2. A more serious issue was that initially I got both p and s arrivals but after using for some time I have started getting only p arrival. The s is zero. I tried debugging but could not find any solution. Even if I copy and paste an example from tutorial I get the same behaviour.
    I will be highly grateful for your reply as I am quite stuck at this issue.
  1. sounds similar to this: Access violation when using ar_pick algorithm · Issue #2642 · obspy/obspy · GitHub

  2. Hmm… not sure what’s going on, but you say that you used to get P+S and now with the same data you only get P? That sounds weird…

The first issue occurs on just one particular event data and works on all others. At least I have a rough work around but the second problem is really more frustrating as nothing seems to fix it. I used to have both P and S using the same code and data but get only the P arrival now no matter what I try. I have no idea where this is coming from.

I’d ask you to maybe try an older obspy version if it used to give different results, but the last change in AR I can see is from obspy 1.2.0, so I don’t think goin back in obspy versions should make a difference.
I also don’t use that routine myself, so can’t really say much.