Problems with old programs when running on newer ObsPy versions

As an unprofessional in programming, I am currently using module Obspy in the programs. And I am struggling with “ImportError: No module named xseed.utils” which used to work on Anaconda with Obspy==1.0.2, perfectly: with Python==2.7.

However, recently, I have to transfer everything to Linux (Ubuntu 20.04) platform and I can only install Obspy==1.1.0 using “pip”, so on. My guess is there is some problems with “xseed.utils” and Obspy=>1.1.0.

Therefore, I was wondering if you could give me any suggestion what is the problem about this, then how to solve it, and how to get Obspy==1.0.2 on Ubuntu.

I will be waiting for your reply and thank you in advance.

Not sure what you mean by "I have to transfer", but if you copy the installation to a completely different platform it might not work.

I would recommend making a fresh installation on your new machine, like outlined in the github wiki installation page using anaconda.

I meant I’m running the same code on Ubuntu, as used to be on Anaconda (Windows10).
It perfectly works on Anaconda (Obspy==1.0.2), however, since I ran it on Ubuntu (Obspy==1.1.0) which the oldest version I can get with pip, the code shows error as showing.

Ok, so I guess this might be about the big restructuring we did, moving to ObsPy version 1.0.0. You should have gotten DeprecationWarnings all the time if that is the case. In any case, please take a look at the very detailed “What’s New?” pages for our major releases, everything should be explained there:

1 Like

Thank you so much.

obspy.mseed => obspy.io.mseed

You’re welcome, we had DeprecationWarnings showing up for each import that would have had to be changed all through the ObsPy 1.0.x version cycle, but most people just ignore these anyway… :wink: