Problems installing ObsPy

At some time I’m struggling to install ObsPy for python 2.7 using Anaconda on OsX. The install seems ok, the problem is when I run obspy-runtests, I obtain a bunch of errors and at the end report is frustrating: FAILED (failures=49, errors=18). After I tried several things, in desperate I uninstall ObsPy and install with pip and ran the tests. The failures and errors number decrease (failures=16, errors=2) but it is not enough to pass. Bellow are the test results.

I wondering if someone can give some tips to make ObsPy work.

João Fontiela

Running /Users/joaofontiela/anaconda2/lib/python2.7/site-packages/obspy/scripts/runtests.pyc, ObsPy version ‘1.1.0’

Hi Joao,

most of the issue you have reported have already been fixed in the development version on github. We’re just a bit slow in releasing a new ObsPy version…

They are mainly related to changes in how numpy prints arrays.

The from obspy.core.compatibility import mock problem might be caused by the mock package not being installed on your system. It is built into Python with versions >= 3.3 but it should also be installed with the ObsPy conda package. Running pip install mock might fix it for you - otherwise we might have to dig a bit deeper. Please hop into our chatroom () in case you need help.

Last but not least: If you don’t have a very specific reason to use Python 2, please go to Python 3. Python 2 will be end of life very soon.

All the best,