ObsPyck on Mac


I would like to install ObsPyck on my Mac OS X (10.6). I had already installed Obspy and build up the virtual environment with the assistant.
My question is, is which directory should I copy the ObyPyck files from that SVN repository and is it then enough to execute ./Makefile?

Thanks for help

Hi Lee-Jay,

you can copy it wherever you want. The simplest solution is of course to check out the repository.

The caveat is that there is one heavy-weight dependency of ObsPyck that is not included in the ObsPy
OSX installer:


Installing it is unfortunately quite a hassle. In the following I will lay out one possible way
to do it by installing it into the virtual environment. Always make sure to use the python
executable from the virtual environment.

1. Install Qt via homebrew (Install homebrew - http://mxcl.github.com/homebrew)
  brew install qt

2. Install SIP:
* Download from http://www.riverbankcomputing.co.uk/software/sip/download
* Usually SIP can only be used with a Python installed as a Framework. To change this, uncomment the lines around 'error("SIP requires Python to be built as a framework")' in sipconfig.py and siputils.py.
* python configure.py
* make
* make install

3. Install PyQt
* Download from Riverbankcomputing
* python configure.py -q `which qmake`
* make
* make install

That should work. Please keep in mind that ObsPyck is also dependent on a rather large number
of external binaries and a SeisHub server.

I will look into ways to ease the installing of PyQt in cooperation with the ObsPy OSX app.

Best wishes!


Hi Lion,
thanks for your help.

After installing the named programs, I want to execute the Makefile with make, but the following error Message appears:

pyuic4 qt_designer.ui > qt_designer.py
Traceback (most recent call last):
  File "/Users/Lee-Jay/ObyPy_VirEnv/lib/python2.7/site-packages/PyQt4/uic/pyuic.py", line 31, in <module>
    from PyQt4 import QtCore
ImportError: No module named PyQt4
make: *** [qt_designer] Error 1

But I have installed PyQt4 - what's wrong?


Hi Lee-Jay,

you do not need to use make, just running obspyck.py (with the other
files in the same directory) is enough. However the error message you
posted is indeed indicating a problem with the PyQt installation.


I tried it also with this error message - even after reinstalling PyQt:

Traceback (most recent call last):
  File "obspyck.py", line 58, in <module>
    from qt_designer import Ui_qMainWindow_obsPyck
ImportError: cannot import name Ui_qMainWindow_obsPyck


Hello Lee-Jay,

did you verify that PyQt is installed correctly?

You can "test" it with e.g.

  python -c "from PyQt4 import QtCore"

Also make sure to launch ObsPyck from its own directory.

Best wishes,


The last error message occurred, when a launch ObsPyck from its directory.
And when I check PyQt (with your code) this message came:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: cannot import name QTCore

But brew told me, that qt is installed...


I deinstalled everything and tried again:
After installing Qt with homebrew I tested it with
* brew test qt

and got this:
Testing qt
==> /usr/local/Cellar/qt/4.8.2/bin/qmake --version

Then I installed SIP (with no problems) and then PyQt. After
* python configure.py -q 'which qmake'
this messages appears several checkings and generatings:

Qt Designer plugin disabled because Python library is static

Maybe here is the error? Or is this normal? I installed everything as user not as root.


Hej at all,

now the test are all done and fine, I have a problem to start ObsPyck with a local file. Here my command:
(obspy)sec21-dynip-165:VirtualEnv_by_ObsPy soontirfel$ python obspyck.py -t 2007-12-17T15:30:00 -d 1800 -f Users/me/Documents/Data/e3004071217153000.pri0

and the output: