obspy.core.util error

Dear all,

I recently updated my production server to the latest version of obspy modules ( I have installed all the modules available and in their stable release, through pypi) and seishub server.
Everything is working fine except for what follows:
I need to manually index a set of directory that must be accessed through Seishub. The command I issued was:

  obspy-indexer -d /srv2/Data/MIIC/targets/Ketzin/2008_B=*.hhe *.hhn *.hhz,/srv2/Data/MIIC/targets/Ketzin/2009_B=*.hhe *.hhn *.hhz -u postgresql://.....<connection_string>.....:5432/seishub -n 12 -v -l indexing.log --run_once

This is the error I got:

Traceback (most recent call last):
   File "/usr/local/bin/obspy-indexer", line 9, in <module>
     load_entry_point('obspy.db==0.5.1', 'console_scripts', 'obspy-indexer')()
   File "/usr/local/lib/python2.7/dist-packages/distribute-0.6.26-py2.7.egg/pkg_resources.py", line 337, in load_entry_point
     return get_distribution(dist).load_entry_point(group, name)
   File "/usr/local/lib/python2.7/dist-packages/distribute-0.6.26-py2.7.egg/pkg_resources.py", line 2283, in load_entry_point
     return ep.load()
   File "/usr/local/lib/python2.7/dist-packages/distribute-0.6.26-py2.7.egg/pkg_resources.py", line 1993, in load
     entry = __import__(self.module_name, globals(),globals(), ['__name__'])
   File "/usr/local/lib/python2.7/dist-packages/obspy.db-0.5.1-py2.7.egg/obspy/db/scripts/indexer.py", line 10, in <module>
     from obspy.db.indexer import worker, WaveformFileCrawler
   File "/usr/local/lib/python2.7/dist-packages/obspy.db-0.5.1-py2.7.egg/obspy/db/indexer.py", line 5, in <module>
     from obspy.core.util import _getPlugins
ImportError: cannot import name _getPlugins

I tried to switch to the "dev" version of obspy.core but still the util module doesn't contains a _getPlugins name.

Any idea about a possible solution? Thanks in advance for the help.


Hi Eraldo,

try updating the obspy.db to dev version, I think that should do it.
There was some change in obspy.core that seems to be incompatible with
the relatively old obspy.db tagged version.


Dear Tobias,

Thanks a lot for your immediate answer ... updating to the dev branch of obspy.db solved the problem.


Quoting Tobias Megies <megies@geophysik.uni-muenchen.de>: