Meet problems when using `MassDownloader` to download data

I used MassDownloader to download seismic data, it worked well before today, but raised bug today:

ValueError: Could not parse the WADL at ‘’. Invalid WADL?
/xxx/anaconda3/envs/seis/lib/python3.10/multiprocessing/ ResourceWarning: unclosed running multiprocessing pool <multiprocessing.pool.ThreadPool state=RUN pool_size=28>

I tried to kill the associated process (even using the command killall -u username), but it didn’t work and still raise the Error above. Further, I tested a toy scripts using from multiprocessing import Pool, it worked well.

Looks like some changes on the server side maybe, looks like there is a redirect that is changing the URL we try to fetch for the application.wadl (that piece “nnsn_eqcat” shouldn’t be there)? You might have to find a technical contact at UIB/Norsar to figure this one out.

My guess is they might have switched to using two different sub-systems providing station+dataselect vs. events and some redirects aren’t set up right.


@LevCarlo should be fixed on server side

copy that, 3Q. :grinning: :grinning: :grinning: