Calling stream.remove_response without response info

Why does the following code not warn me there is no response file/info?
from obspy import read

The reason I am asking, is because I had a strange experience today: I was using

st = client.get_waveforms(attach_response=True)

and was getting waveform data, but no response info, still:


passed without errors or warnings.


Are you sure there is no response information attached for the downloaded data? Maybe its kind of erroneous identity response?
The example stream already has a response attached.

In [1]: stream = read()
In [2]: del stream[0].stats.response
In [3]: stream.remove_response()
ValueError: No response information found. Use `inventory` parameter to specify an inventory with response information.

Ah! That explains probably most of my question. I did not know that read() included response info.

Is it possible that in my “real” problem today the FDSN service worked for the data part, but not for the response file? Can there be such a hick-up in FDSN service? For the record, the same data request for data+response works now, so I actually cannot reproduce the issue.

Thanks for your help.

Maybe. That is what I meant with “erroneous response”. But hard to tell if it’s not reproducible.

Good, that it works now.